Option file for CPLEX solver

Solver related questions
mosalari
User
User
Posts: 5
Joined: 7 months ago

Option file for CPLEX solver

Postby mosalari » 3 weeks ago

Hi all,
I use CPLEX solver to solve the MIP problems, but this solver tends to give the results as below for instance:

MIP Solution: 207.200000 (9469739 iterations, 151607 nodes)
Final Solve: 207.200000 (0 iterations)

Best possible: 151.594951
Absolute gap: 55.605049
Relative gap: 0.268364

I wanna have zero absolute or relative gap while solving the MIP problems so I used the Optionfile to set the Absoulutegap and relative gap values to zero. The solver, however, still gives results with the absolute and relative gaps more than zero. To me, it seems that I need to set more criteria to get the results with zero gaps. Can anyone help me on this?

P,s: To let you know, here is the criteria I set in the option file:

epagap=0
epgap=0
epint=0
solnpoolagap=0
solnpoolgap=0

User avatar
bussieck
Moderator
Moderator
Posts: 48
Joined: 11 months ago

Re: Option file for CPLEX solver

Postby bussieck » 3 weeks ago

There are two possibilities: a) GAMS/CPLEX did not process the option file, or b) Cplex terminated on time/iteration/... limit. The log will tell you more. You should find an echo of the options processed and also the reason why Cplex terminated.

-Michael

yanzhiping
User
User
Posts: 83
Joined: 6 months ago

Re: Option file for CPLEX solver

Postby yanzhiping » 3 weeks ago

absolute gap is the upper bound for the distance between best integer and optimal solution is “best estimate” - “best integer”.
https://support.gams.com/solver:what_is_optca_optcr

instead of creating a cplex option file, try to do in GAMS,

Code: Select all

Option
* relative termination tolerance for use in solving MIP problems
    optcr=0,
*absolute gap
   optca=0;

mosalari
User
User
Posts: 5
Joined: 7 months ago

Re: Option file for CPLEX solver

Postby mosalari » 3 weeks ago

GAMS read the options file.
here is the report from GAMS:

MIP status (107): time limit exceeded

So, it seems the problem is the time limit. How can I have an unbounded time limit?


bussieck wrote:There are two possibilities: a) GAMS/CPLEX did not process the option file, or b) Cplex terminated on time/iteration/... limit. The log will tell you more. You should find an echo of the options processed and also the reason why Cplex terminated.

-Michael

mosalari
User
User
Posts: 5
Joined: 7 months ago

Re: Option file for CPLEX solver

Postby mosalari » 3 weeks ago

Thank you. I tried it but it doesn't work. I still have an absolute gap.

here is the report from GAMS:
MIP status (107): time limit exceeded

So, it seems the problem is the time limit. How can I have an unbounded time limit?

yanzhiping wrote:absolute gap is the upper bound for the distance between best integer and optimal solution is “best estimate” - “best integer”.
https://support.gams.com/solver:what_is_optca_optcr

instead of creating a cplex option file, try to do in GAMS,

Code: Select all

Option
* relative termination tolerance for use in solving MIP problems
    optcr=0,
*absolute gap
   optca=0;


Return to “Solvers”

Who is online

Users browsing this forum: No registered users and 1 guest