Page 1 of 1

HELP: error - superbasics limit is too small !!!

Posted: Mon Jun 11, 2018 11:13 pm
by 94470123
Hello everyone
I'm trying to optimize a dynamic scenario-based problem using nlp snopt, but i face this error: superbasics limit is too small !!! .
The funny point is that the problem is optimized for 16 hours but when model is run for 17 hours or more this error comes up.
what can i do ? please help me.
I would really, deeply and highly appreciate your help and guidance.

Re: HELP: error - superbasics limit is too small !!!

Posted: Tue Jun 12, 2018 9:07 am
by Renger
Hi
You probably have to increase this limit. Take a look at the snopt manual how to do this.
Cheers
Renger

Re: HELP: error - superbasics limit is too small !!!

Posted: Tue Jun 12, 2018 11:40 am
by 94470123
Renger wrote:
1 year ago
Hi
You probably have to increase this limit. Take a look at the snopt manual how to do this.
Cheers
Renger
Hi
Thank you
I've checked the snopt manual but couldn't figure out how to increase the limit.

Re: HELP: error - superbasics limit is too small !!!

Posted: Wed Jun 13, 2018 7:46 am
by Renger
Hi
Have a look here how to set options for a solver https://www.gams.com/latest/docs/UG_SolverUsage.html. (under "The Solver Options File") and set the
superbasics limit to a different value.
(From the SNOPT documentation: "The performance of GAMS/SNOPT is controlled by a number of parameters or "options." Each option has a default value that should be appropriate for most problems. For special situations it is possible to specify non-default values for some or all of the options via the SNOPT option file. While the content of an option file is solver-specific, the details of how to create an option file and instruct the solver to use it are not. This topic is covered in section The Solver Options File.")

Cheers
Renger