MINOS infeasible but CPLEX optimal

Solver related questions
Post Reply
jch
User
User
Posts: 5
Joined: 1 year ago

MINOS infeasible but CPLEX optimal

Post by jch » 8 months ago

I am using GAMS 30.3.0 ( Cplex 12.10.0.0, MINOS 5.6 ) to solve one problem.

Cplex returns optimal solution with MODEL STATUS of 1 Optimal.
MINOS says infeasible with MODEL STATUS of 4 Infeasible.

Why? How to fine the reason and solve this issue? Thanks.

User avatar
dirkse
Moderator
Moderator
Posts: 154
Joined: 4 years ago
Location: Fairfax, VA

Re: MINOS infeasible but CPLEX optimal

Post by dirkse » 8 months ago

jch,

This happens occasionally and can be very frustrating. Sometimes the feasibility of a model can depend on tolerances: if CPLEX uses looser tolerances, that might lead to feasibility.

Another issue is scaling. If you have very large numbers in your model (variable levels, coefficients, RHS) it can exhibit behavior like you observe.

I suggest you run the model with the CPLEX option datacheck=2 and you'll get some suggestions from CPLEX about what is wrong or potentially problematic with your model.

You could also try running MINOS starting with the CPLEX-provided solution, i.e. with a second solve immediately after the CPLEX solve.

Finally, you could run CPLEX under the Examiner tool. This will get you an independent assessment of the feasibility of the CPLEX-provided solution.

-Steve

jch
User
User
Posts: 5
Joined: 1 year ago

Re: MINOS infeasible but CPLEX optimal

Post by jch » 8 months ago

hi dirkse, thank you very much for the reply. What is the Examiner tool and where to get it?

I changed the LP solver from MINOS to GUROBI, and the same issue happened: CPLEX found a solution, but GUROBI did not.

I added the CPLEX option datacheck=2, and fixed some data issues based on the output, but GUROBI still cannot find a solution because of "infeasible or unbounded".

Then I tried you suggestion of "running GUROBI starting with the CPLEX-provided solution, i.e. with a second solve immediately after the CPLEX solve." This time GUROBI find a solution.

I didn't know what to do. so I read the BUROBI documents on the GAMS website, and found this option: Option SysOut = On;

After using it, a log message suggested to set NumericFocus parameter to 1~3 for GUROBI.

I set NumericFocus to 1, GUROBI found a solution now.

Thank you.

Post Reply