Why is GAMS stucked at an elapsed time during searching for a solution? Topic is solved

Solver related questions
Post Reply
dunyayigezerken
User
User
Posts: 29
Joined: 2 years ago

Why is GAMS stucked at an elapsed time during searching for a solution?

Post by dunyayigezerken » 7 months ago

Hi,

I have a MILP problem, when I started the GAMS, it stucked at elapsed time = 6518.72 sec.
However, I defined ;

option mip=cplex;
option lp=cplex;
option optcr=0;
option iterlim=1000000000;
option reslim=10800;

The GAMS is still running, however the screen which shows active processes doesnt change, frozen. Is it a problem addressed with my computer or GAMS? Have you got any experience about it? I know my HDD has some bad sector. But, the problem with GAMS just started to happen , before 1 week it seems normal.

SapperDoc
User
User
Posts: 13
Joined: 1 year ago

Re: Why is GAMS stucked at an elapsed time during searching for a solution?

Post by SapperDoc » 7 months ago

To verify that it's not your computer, try solving it via the NEOS Optimization Server. There's an 8 hour time limit on jobs (if I recall correctly), and you can't write output files, but you can get the GDX output returned to you!

User avatar
bussieck
Moderator
Moderator
Posts: 617
Joined: 4 years ago

Re: Why is GAMS stucked at an elapsed time during searching for a solution?

Post by bussieck » 7 months ago

There are phases in Cplex that can take a very very long time (e.g. processing of node 0) without messages to the log. If you send more of your log, then perhaps we can answer better. -Michael

dunyayigezerken
User
User
Posts: 29
Joined: 2 years ago

Re: Why is GAMS stucked at an elapsed time during searching for a solution?

Post by dunyayigezerken » 7 months ago

Ekran Alıntısı.PNG
I tried another model and the systems stucks like that on the image.
MOdel is working but process screen does not update. And when the resource limit exceeded the results give 3.11% gap where the model stucked.
Last edited by dunyayigezerken 7 months ago, edited 2 times in total.

dunyayigezerken
User
User
Posts: 29
Joined: 2 years ago

Re: Why is GAMS stucked at an elapsed time during searching for a solution?

Post by dunyayigezerken » 7 months ago

bussieck wrote:
7 months ago
There are phases in Cplex that can take a very very long time (e.g. processing of node 0) without messages to the log. If you send more of your log, then perhaps we can answer better. -Michael
Ekran Alıntısı.PNG
I tried another model and the systems stucks like that on the image.
Model is working but process screen does not update. And when the resource limit exceeded the results give 3.11% gap where the model stucked.

dunyayigezerken
User
User
Posts: 29
Joined: 2 years ago

Re: Why is GAMS stucked at an elapsed time during searching for a solution?

Post by dunyayigezerken » 7 months ago

SapperDoc wrote:
7 months ago
To verify that it's not your computer, try solving it via the NEOS Optimization Server. There's an 8 hour time limit on jobs (if I recall correctly), and you can't write output files, but you can get the GDX output returned to you!
When I changed a constraint, the model is running and also MATLAB even works fine with GAMS simultaneously. It does not make sense about 1 constraint creates this stuck.

The constraint is like

Code: Select all

a: positive var.
b: parameter
c, d: integer variable

constraint.. a = b - c + d
... other constraints...
obj.. sum(c - d)
so I try to max c and min d, imagine that c is time saving and d is delay.

User avatar
bussieck
Moderator
Moderator
Posts: 617
Joined: 4 years ago

Re: Why is GAMS stucked at an elapsed time during searching for a solution?

Post by bussieck » 7 months ago

Yes, this seems odd. It could be that Cplex is stuck solving the node lp. You could turn on the detailed node log by setting option mipdisplay = 5. This will give you much more output (all the LP logs from the nodes) but might give you an idea what's wrong. If you are using the latest version of Cplex and it is indeed hanging at a node lp, you should let support@gams.com know about this (with a model that reproduces the behavior).

-Michael

dunyayigezerken
User
User
Posts: 29
Joined: 2 years ago

Re: Why is GAMS stucked at an elapsed time during searching for a solution?

Post by dunyayigezerken » 7 months ago

bussieck wrote:
7 months ago
Yes, this seems odd. It could be that Cplex is stuck solving the node lp. You could turn on the detailed node log by setting option mipdisplay = 5. This will give you much more output (all the LP logs from the nodes) but might give you an idea what's wrong. If you are using the latest version of Cplex and it is indeed hanging at a node lp, you should let support@gams.com know about this (with a model that reproduces the behavior).

-Michael
Thank you, Michael, it is not last version, but I will try to write option code you shared.

User avatar
bussieck
Moderator
Moderator
Posts: 617
Joined: 4 years ago

Re: Why is GAMS stucked at an elapsed time during searching for a solution?

Post by bussieck » 7 months ago

I would first try to see if you can reproduce this with the latest version. You could e.g. submit to NEOS and use the latest version there. -Michael

dunyayigezerken
User
User
Posts: 29
Joined: 2 years ago

Re: Why is GAMS stucked at an elapsed time during searching for a solution?

Post by dunyayigezerken » 7 months ago

bussieck wrote:
7 months ago
I would first try to see if you can reproduce this with the latest version. You could e.g. submit to NEOS and use the latest version there. -Michael
Hello Michael,

Thanks for your advise. However, I think that I solved the problem.

I guess that the solver tries to prove all branches before cutoff and it stuck at possible solution 590 at gap score 0.25. Hence, I added cutoff = 590 to speed up the model for below 590 solutions on the trees. And that is it, the program jumped another gap score from where it stuck and give "proven optimal solution" as 590 and it lasted 2700 sec. I hope this strategy is good to go. cutoff is really awesome thing in GAMS.

Post Reply