MPSGE

Solver related questions
Post Reply
kapsalyamova
User
User
Posts: 3
Joined: 9 months ago

MPSGE

Post by kapsalyamova » 9 months ago

Dear GAMS users,

after downloading GAMS Studio on the PC and acquiring DEMO license, we encountered the problem with MPSGE solver.
For some reasons when you run a model in equation format the GAMS runs well and delivers a solution. However, while using a code that requires MPSGE solver, we get
MPSGE problem.pdf
(121.55 KiB) Downloaded 121 times
the error 282 in C:\\GAMS\38\mpsgeset
Unable to open include file. Hint: does the filename need to be....

The same code is run with no errors on other machines. I guess the problem boils down to this PC on which the error is generated. Could you please help to find a solution. Many thanks.

Best regards,
Zhanna

Fred
Posts: 323
Joined: 6 years ago

Re: MPSGE

Post by Fred » 9 months ago

Hi Zhanna,

the log indicates that the first error is a missing include file. You can find further details about which include file cannot be found in the lst file.

I hope this helps!

Fred

kapsalyamova
User
User
Posts: 3
Joined: 9 months ago

Re: MPSGE

Post by kapsalyamova » 9 months ago

Dear Fred,

thank you, yes, that is partly true. But why the same code runs on other machines. What might be missing here?
image (5).png
I added another attachment. The problem is specifically with MPSGE solver. I just don't know how to go around it.

Thanks.
Best regards,
Zhanna

Fred
Posts: 323
Joined: 6 years ago

Re: MPSGE

Post by Fred » 9 months ago

Hi Zhanna
But why the same code runs on other machines.
I assume because the file that is missing in your machine exists on the other machine.

The problematic line

Code: Select all

$include %hdr%
encodes the file name through a compile time variable hdr. This must be set either somewhere in your code (e.g. via $set hdr someFileName) or when you start the GAMS Job you have to provide a corresponding double dash parameter --hdr=someFileName.

All this depends on the content of your model. So if the problem persists, please share your log file, your lst file and all your code and data files such that other forum users can try to reproduce what you are doing. Otherwise it is difficult to provide help.

Best,
Fred

kapsalyamova
User
User
Posts: 3
Joined: 9 months ago

Re: MPSGE

Post by kapsalyamova » 9 months ago

Dear Fred,

thank you very much for your response. The files are attached.
m1_mp.log
(2.69 KiB) Downloaded 101 times
m1_mp.gms
(2.06 KiB) Downloaded 112 times
m1_mplst.gms
(5.24 KiB) Downloaded 107 times
Listing file is stored as gms file, because for some reasons .lst files were not possible to upload. Thank you.

User avatar
dirkse
Moderator
Moderator
Posts: 194
Joined: 6 years ago
Location: Fairfax, VA

Re: MPSGE

Post by dirkse » 9 months ago

Zhanna,

This is a strange error, and it's more difficult for you to engage with because it's happening inside the mpsgeset sysinclude file in the GAMS sysdir.

I am attaching a hacked-up version of mpsgeset that will help figure this out. Please do:

1. Copy the attached next to the original mpsgeset on your system.
2. Edit your GAMS input file to $sysinclude mpsgesethack instead of mpsgeset
3. Put a $exit statement after the first solve in your .gms file (no need for more than one solve)
4. Run it
5. Have a look at the file parfile.txt that should get placed next to your input .gms file.
6. If you don't get any ideas from this, come back with this parfile.txt.

I had to rename mpsgesethack -> mpsgesethack.gms to attach it.

Hope this helps,

-Steve
mpsgesethack.gms
(1.94 KiB) Downloaded 109 times

Post Reply