Barons restricting the iteration numbers

Solver related questions
Post Reply
danish3186
User
User
Posts: 6
Joined: 9 months ago

Barons restricting the iteration numbers

Post by danish3186 » 9 months ago

I am solving a nlp using barons, I tried restricting the number of iterations to a fixed value like 100.
I am sending my problem to neos and it always solves problem to optimality.

I am adding the following code to restrict iterations

Code: Select all

$onecho > baron.opt
MaxIter 100
$offecho


How can I restrict the number of iterations?

Thanks!

Ebru
User
User
Posts: 9
Joined: 10 months ago

Re: Barons restricting the iteration numbers

Post by Ebru » 9 months ago

Hi,

I solved this problem as adding the following code set.

Code: Select all

model yourmodel /all/;
$onecho > baron.opt
MaxIter 100
$offecho

yourmodel.optfile = 1;

option minlp = baron;
solve yourmodel using minlp minimizing z_value;

Post Reply