Parallel Mode and Number of Threads Setting in cplex.opt file

Solver related questions
Post Reply
Jubeyer
User
User
Posts: 36
Joined: 2 years ago

Parallel Mode and Number of Threads Setting in cplex.opt file

Post by Jubeyer » 1 month ago

Hi,
I have set,

threads=0
and
parallelmode=-1

in the cplex.opt file ; but while executing the logfile is not showing up those values. Can anyone tell me how to define them correctly?

Best Regards.

User avatar
bussieck
Moderator
Moderator
Posts: 859
Joined: 6 years ago

Re: Parallel Mode and Number of Threads Setting in cplex.opt file

Post by bussieck » 1 month ago

Did you follow all instructions described here (https://www.gams.com/latest/docs/UG_Sol ... PTION_FILE) to enable the option file reading by the solver, most importantly setting mymodel.optfile=1?

-Michael

Jubeyer
User
User
Posts: 36
Joined: 2 years ago

Re: Parallel Mode and Number of Threads Setting in cplex.opt file

Post by Jubeyer » 1 month ago

Yes, I did.

I have done the following in my .gms file.
MyModel.iterlim =500000;
MyModel.optcr = 0.001;
MyModel.reslim = 1800;
option solvelink=5;
MyModel.optfile = 1;
heaplimit = 30000;

And I have tried to specify the thread number there as well like the following:
MyModel.threads=0;

Fred
Posts: 323
Joined: 6 years ago

Re: Parallel Mode and Number of Threads Setting in cplex.opt file

Post by Fred » 1 month ago

Looks correct. Please share your gms and log file. Fixing a problem with partial information is difficult.

Fred

Post Reply