Page 1 of 1

results multiplied by 10^4

Posted: Wed Jan 13, 2021 1:46 pm
by eceucar
Hi everybody,

Hope you're all doing well,

I have a problem with Data envelopment analysis model. The problem is I have the model and solutions in my hands, but when I code the model to Gams I could not find the same solutions. I found the solutions multiplied by 10^4 for variables u,v and h.

Thank you for your cooperation, it is very important for my master thesis...
Kind regards,

Ece U├žar.
Untitled_13.gms
(3.43 KiB) Downloaded 16 times

Re: results multiplied by 10^4

Posted: Thu Jan 14, 2021 3:26 pm
by dirkse
Ece,

So, you have a model and know a solution to this model, but when you code it in GAMS, you get a different solution. There are several possible causes for this, including:

1. The model has multiple solutions. Both the a priori solution and the GAMS-computed solution could be good.

2. The GAMS model is not coded correctly.

3. The a priori solution is not really a solution.

Where to start? I suggest you fix (in the GAMS run) some/all of the variables u, v, and h to the known solution values. If you get solutions that then match the a priori solution, you have a demonstration that multiple solutions exist.

If not, then you have evidence that your two models (the initial one and the GAMS one) are different. To discover how/why they are different is part science and part art. I would first simplify the problem, e.g. don't make it a DEA analysis but instead make it one LP model. Fix the values in the GAMS model to the known solution. Do you see violated constraints in the equation listing? Do you get a solution but a worse one (in obj value sense) than without fixing variables? These all tell you something about the two models.

HTH,

-Steve

Re: results multiplied by 10^4

Posted: Thu Jan 14, 2021 3:44 pm
by eceucar
thank you very much, I appreciate your response,

Kind regards,

Ece.