Index pane of .lst

questions about GAMS' tools
optie
User
User
Posts: 7
Joined: 1 year ago

Index pane of .lst

Post by optie » 1 year ago

Dear all,

I am wondering how to show the index pane of .lst file in GAMS studio? Index pane is the below image. It comes automatically when using IDE but I cannot find any way to see this tree structure of index pane when looking at .lst file in GAMS Studio. Can anybody help? I am using version 31.1.1. Thanks.

Image
Attachments
index pane.PNG
index pane.PNG (6.24 KiB) Viewed 2966 times

Lutz
User
User
Posts: 41
Joined: 5 years ago

Re: Index pane of .lst

Post by Lutz » 1 year ago

Hi,

By default, it should be there, just like in the IDE. I just tried it:
image.png
The logic for showing this is actually the same in the IDE and Studio: If the file <output>.lxi exists next to <output>.lst, this is shown. Otherwise not. And this lxi file gets created, if you run your model from the IDE or from Studio (it is not created by default, if you run from the command line). It could actually happen, that the pane got minimized. In this case, you could move the cursor to the left of the lst view. It will change to indicate, that you can adjust the size of the panes. From there, you could increase/unhide the missing pane again.

Hope that helps,
Lutz

optie
User
User
Posts: 7
Joined: 1 year ago

Re: Index pane of .lst

Post by optie » 1 year ago

Hi,
Thanks for your reply. Actually, when the model is solved then .lst and .lxi and .log will be created but still I have not this pane on the left! Besides, .lst file itself can be open in Studio and IDE but in my case similar .lst file have the index pane in IDE but not in Studio!

I also checked minimization of the pane (or maybe hide somewhere) but it is not happening for me.

Thanks.

optie
User
User
Posts: 7
Joined: 1 year ago

Re: Index pane of .lst

Post by optie » 1 year ago

More information:
I ran another code by myself and also a code from GAMS library and the index pane appear! But I ran two other different codes written by myself and index pane is not appearing in Studio! But it comes in IDE, very strange! Maybe some specific object in a written code can cause it. If I find the reason then I will report it, until then I will be thankful if anyone has similar experience. Thanks.

Lutz
User
User
Posts: 41
Joined: 5 years ago

Re: Index pane of .lst

Post by Lutz » 1 year ago

Does it happen like this for all models or just a particular one? Can you try the following:

- Close Studio
- Use the command line to navigate to <GAMS Dir>\Studio
- Run "studio.exe --ignore-settings"
- Run trnsport and open trnsport.lst

Do you see the lxi pane for that one?

Best regards,
Lutz

optie
User
User
Posts: 7
Joined: 1 year ago

Re: Index pane of .lst

Post by optie » 1 year ago

It happens just for some models!

I didn't understand "--ignore-settings" part but anyway for trnsport model I have the pane and as I said I have this pane for some other models as well but for some models it will not appear; however, the lxi is created and I can open it in IDE but not in studio.

Lutz
User
User
Posts: 41
Joined: 5 years ago

Re: Index pane of .lst

Post by Lutz » 1 year ago

Sorry, I did not see, that you had two posts between my two, I just saw the first one before my last reply.

--ignore-settings should just make sure, that no setting of Studio got broken in some way (see https://www.gams.com/latest/docs/T_STUD ... NE_OPTIONS), but since you wrote already, that things are working for some models, you can just ignore this.

Is it possible to send the lst and lxi file which causes problems to support@gams.com? I would like to try to reproduce this.

Best,
Lutz

optie
User
User
Posts: 7
Joined: 1 year ago

Re: Index pane of .lst

Post by optie » 1 year ago

I found the strange reason!
Thanks for your help. I copied my .gms file and wanted to send you and then I tried it once more but it worked! Why? Just because of its name! I rename the .gms file but it affects the index pane! For example, please save the "trnsport.gms" file with the name of "1. trnsport.gms" and then run it. Can you see the index pane? I cannot and I think you cannot either! But if you rename it without number and dot (1. ) in the first of its name everything will fix. This is the reason some of my files have not this index pane because I sorted some of them with number and a dot!

I think it can be a very minor bug. Please try my example and if you still didn't get it completely inform me because I want to assist GAMS to fix this bug in the next versions. Thank you anyway.

Lutz
User
User
Posts: 41
Joined: 5 years ago

Re: Index pane of .lst

Post by Lutz » 1 year ago

Thank you very much for this report! I can reproduce it and this is definitely no wanted behavior. I hope, that we have a fix for this with the next release.

Best regards,
Lutz

optie
User
User
Posts: 7
Joined: 1 year ago

Re: Index pane of .lst

Post by optie » 1 year ago

You're welcome.

Thanks for your quick replies.

Kind regards,
A GAMS user!

Post Reply