issues running GAMS with MacOS Catalina

Post Reply
User avatar
dirkse
Moderator
Moderator
Posts: 85
Joined: 3 years ago
Location: Fairfax, VA

issues running GAMS with MacOS Catalina

Post by dirkse » 1 month ago

Hello,

On Monday, 7 Oct, Apple released macOS Catalina (10.15). At the moment, GAMS does not "just run" on this version of macOS. Instead, when you run GAMS, you are notified that "the developer of the executable could not be identified".

If you upgrade to MacOS Catalina, you can use the following workaround to make GAMS run again:
- Launch GAMS (e.g. through GAMS Studio or the GAMS Terminal App) and you will be warned that the developer of the executable could not be identified.
- You get the options to cancel or move the executable to the bin. Click "Cancel".
- Now, you can allow execution anyway by going to "System Preferences" -> "Security&Privacy" -> In the section "General"/"Allow apps downloaded from" you can allow the problematic dylib/executable manually by clicking "Allow Anyway". This has to be done step by step for every dylib/executable you get warnings for. Each solver or GAMS utility or tool has its own set of libraries or executables, so this is a somewhat tedious process.

We are searching for a solution to this problem and will continue to make this a high priority until a resolution is found.

We recommend that all those using GAMS on a Mac keep the issue and process described above in mind when considering an update to macOS Catalina. We apologize for any inconvenience.

Your GAMS Team

Fred
Posts: 166
Joined: 3 years ago

Re: issues running GAMS with MacOS Catalina

Post by Fred » 3 weeks ago

Dear GAMS Users,
In the meantime, we found a much simpler workaround for the issue with macOS Catalina (10.15).
You can open the GAMS Terminal app and enter the following:

Code: Select all

cd /Applications/GAMS28.2/ && xattr -rd com.apple.quarantine sysdir/
Note that you might have to adjust the path (/Applications/GAMS28.2/) depending on the GAMS version you want to run. Afterwards, you should be able to run gams as you used to.
We are continuing our work on the issue and keep this a high priority until a resolution is found.

Your GAMS Team

Alireza.soroudi
User
User
Posts: 8
Joined: 2 years ago

Re: issues running GAMS with MacOS Catalina

Post by Alireza.soroudi » 2 weeks ago

Dear GAMS team,
Thanks for trying to resolve the CATALINA issue. As a matter of fact I have removed my GAMS from my mac (when faced with the Catalina problem).
Would you please let me know how I can reinstall it? it gives me the CPU error when I try to use WINE to install it.
Best regards
Alireza

Fred
Posts: 166
Joined: 3 years ago

Re: issues running GAMS with MacOS Catalina

Post by Fred » 1 week ago

Hi Alireza,

You could install GAMS 29 beta which has been released earlier this week and should just work with Catalina: https://www.gams.com/29/

For older versions, please install the Mac version of GAMS and follow one of the workarounds described in the previous posts of this thread.

I hope this helps!
Fred

Alireza.soroudi
User
User
Posts: 8
Joined: 2 years ago

Re: issues running GAMS with MacOS Catalina

Post by Alireza.soroudi » 1 week ago

Do you have any solution for those users who have windows license but they might need to install it on mac CATALINA?
I am asking because it was already possible with a video on youtube (on older mac versions)
you advised to install the mac version but it needs a mac license to work on mac !
I think when more users upgrade to new mac version you will have more requests like this since it stops working

Post Reply