Getting illogical result Topic is solved

Problems with modeling
Post Reply
AriesTie
User
User
Posts: 2
Joined: 1 month ago

Getting illogical result

Post by AriesTie » 1 month ago

Dear all,

Hi. I am currently working on my final year project regarding water network synthesis or water minimisation. I am new to GAMS and I am facing issue with my second case study which is water network synthesis with partitioning regenerator to minimise the freshwater consumption as well as wastewater flowrate. The figure attached is my superstructure representation with partitioning regenerator:

*Removed*

My objective function and constraints:
*Removed to prevent plagiarism*

My GAMS code is as below:

Code: Select all

 *Removed to prevent similarity in Turnitin* 
The issue I am facing now are:

(i) Partitionig regenerator is a type of regenerator that consists of one inlet and two outlets streams. The two outlet streams are named lean stream A and rich stream B. Rich stream B is a lower quality stream that always has higher contaminant concentration than that of lean stream A. My regenerator is a fixed lean CA-out regenerator where the concentration of my lean stream A is always fixed while the concentration of rich stream B is a variable which depends on the concentration of sources entering my regenerator. My issue now is the result I get is illogical where the concentration of my rich stream B is totally zero which is impossible. It looks like my variable Cb(r) won't take up any value.

(ii) When I change the "=l=" of my MSinkLoad(j) and MLoad_Regenerator(r) equations to "=E=", it happens to me that there is no water flowrate entering my regenerator. I have no idea why it happens.

Please spend a little time to help me troubleshoot my problem as I have stucked on these two issues for a month. I have consulted my supervisor but I ended up didn't get any solution for these errors. Are there any researchers who are working on the similar topics or in the same field can help me to troubleshoot my issues or any GAMS experts that can solve my logical error as well as the "=l=" & "=E=" problems?

Thank you! Your kind assistance will be greatly appreciated.
Last edited by AriesTie 4 weeks ago, edited 1 time in total.

ameeraus
User
User
Posts: 2
Joined: 8 months ago

Re: Getting illogical result

Post by ameeraus » 1 month ago

Hi, interesting problem, here are a few comments that may help:

1) The equation "MLoad_Regenerator(r)" should be =e=

2) This is a highly non convex model and you may want try a global algorithm like BARON. CONOPT will give a local solution only which depends on the initial points, in your case all at zero.

3) giving some initial values to a few variables may help as well, for example try this

....
Model Case2 "Case 2" /ALL/;

CB.l(r) = 1000;

this will get you an objective of 130 and

---- 98 VARIABLE CB.L rich stream B outlet concentration

1 1329.374, 2 746.411

Good luck, I had fun looking at your problem, regards, Alex

AriesTie
User
User
Posts: 2
Joined: 1 month ago

Re: Getting illogical result

Post by AriesTie » 4 weeks ago

Hi, Alex!

Sadly my GAMS only have BARON in demo version, so it can't handle my model. However, setting initial points for some of my variables does work!! Finally, I can have some progress for my project.

Thanks a lot!! I really appreciate your help!!
A-big-thank-you.jpg
Best regards,

Wendy

Post Reply