Having trouble with my gams file

Problems with modeling
Post Reply
Demiafo
User
User
Posts: 1
Joined: 2 months ago

Having trouble with my gams file

Post by Demiafo » 2 months ago

I have currently written two source codes, modelling power system operators, one using LP (simpler one) and the other using an MIP to solve the same problem. When I run both files, I am returned with an infeasible solution or returned with a solution. Upon reading the lst files it seems evident that the problem is resulting from two equations termed as EnergyBalance and EnergyBalance2 (within both files), however conceptually with regards to the system considered both are right. I have run the model multiple times, amending the equation, adding, and removing equations over multiple runs, as well as making use of the Contol+F function to find the infeasibility in the model. However, it still does not work. I don't believe my error comes from my understanding of the process or the equations and from looking at the resulting equations generated I am not able to decipher why the model is still not running. I have also attached 2 gms. I have also seen that i can use iis to help me finding out where the infeasibility is coming from however, there is little information on how to execute that. Any pointers would help.

My error from the LP file:
**** REPORT SUMMARY : 0 NONOPT
0 INFEASIBLE
0 UNBOUNDED
460 PROJECTED

---- 453 VARIABLE TCOST.L = UNDF total costs [pounds]
VARIABLE OPEX.L = 1.027167E+9 operating expenditures [pounds]
VARIABLE CI.L = -1.03672E+9 interconnection costs [pounds]
VARIABLE CC.L = 1.400400E+9 carbon costs [pounds]
VARIABLE CFUEL.L = 5.583970E+7 fuel costs [pounds]

My error from the MIP file:
**** SOLVER STATUS 1 Normal Completion
**** MODEL STATUS 10 Integer Infeasible
**** OBJECTIVE VALUE NA
MIP status(103): integer infeasible
Problem is integer infeasible.

Thank you in advance for any help provided :)
ModelV2.gms
(17.36 KiB) Downloaded 20 times
ModelV3.gms
(15.23 KiB) Downloaded 20 times

Post Reply