Read from Excel running in cluster environment

questions about GAMS' tools
Post Reply
mpap
User
User
Posts: 3
Joined: 9 months ago

Read from Excel running in cluster environment

Post by mpap » 4 months ago

Hello,

I have a GAMS file that currently reads data from Excel. The way I have set this up is through the use of a .gpr so that the GAMS file can see the corresponing Excel one.

I want to run this now in a cluster environment, however there is no GUI for me to open the .gpr first and therefore GAMS doesn't see the corresponding Excel.

Does anyone know how to resolve this? Is there any way to code in the main GAMS file to open the .gpr first?

Thanks,
M

User avatar
Renger
Posts: 406
Joined: 3 years ago

Re: Read from Excel running in cluster environment

Post by Renger » 4 months ago

Hi
I am not sure if I understand you correctly: are you running on an Unix cluster? If yes, the gamside won't work anyway and reading excel files either.
Gamsstudio runs on Linux (but don't ask me how to set it up). Another option would be to open your gams file in a good text editor and run Gams from the command line.

Cheers
Renger

Enjoy modeling even more The lazy economist
____________________________________
Enjoy modeling even more: Read my blog on modeling at The lazy economist

mpap
User
User
Posts: 3
Joined: 9 months ago

Re: Read from Excel running in cluster environment

Post by mpap » 4 months ago

Thank you - I will think of some other way then

M

User avatar
dirkse
Moderator
Moderator
Posts: 87
Joined: 3 years ago
Location: Fairfax, VA

Re: Read from Excel running in cluster environment

Post by dirkse » 4 months ago

You mention running in a cluster, but that could mean many things. Windows or Linux? Will you run this as a batch job or do you want to use a GUI?

One clear advantage of running from a command line: it always works, regardless of the environment. So you can get your stuff running on the command line on your desktop and feel more confident it will run similarly on a cluster - whatever that means.

-Steve

Post Reply