Problem with 'rtnwma' and 'rtnwmi'

Solver related questions
Post Reply
Bonniewang
User
User
Posts: 1
Joined: 6 months ago

Problem with 'rtnwma' and 'rtnwmi'

Post by Bonniewang » 6 months ago

Dear Sir or Madam,

I use GAMS to solve economic models with CONOPT. Here comes my question:

When I run the model with an option file states:

FILE opt CONOPT option file /conopt.opt/;
PUT opt;
PUT ' rtnwma 1E-04'/;
*PUT ' rtnwmi 1E-05'/;
PUTCLOSE opt;

The solution report shows "Normal completion, Locally infeasible". It tells me how to relax the tolerance with 'rtnwmi'. All infeasililities come from very small values. When I change the option file to the following:

FILE opt CONOPT option file /conopt.opt/;
PUT opt;
*PUT ' rtnwma 1E-04'/;
PUT ' rtnwmi 1E-05'/;
PUTCLOSE opt;

It turns out "Minimum Newton tolerance Rtnwmi=1.0E-05" is greater than Maximum Newton Tolerance, Rtnwma=1.0e-07. Change one of them." If I change 'rtnwmi' to smaller than 1.0e-07, then the infeasibility problem cant be removed.

I also tried with turning on both 'rtnwma' and 'rtnwmi' simutaneously, the result turns to be not optimal with '7 INTERMEDIATE NONOPTIMAL'.

Could you please help me with this?

Many thanks,
Bonnie

Fred
Posts: 134
Joined: 2 years ago

Re: Problem with 'rtnwma' and 'rtnwmi'

Post by Fred » 6 months ago

Hi,

If no matter how you set the limits of the feasibility tolerance, the model remains infeasible, the conclusion may be that it really is infeasible. You probably won't change that via solver options but have to work on the model and/or data.

The Conopt solver manual has some hints on good model formulation. Maybe they are of interest to you: https://www.gams.com/latest/docs/S_CONO ... ORMULATION

Regards,
Fred

Post Reply